Ticket #1706 (assigned defect)

Opened 4 years ago

Last modified 9 months ago

Moving pages in CMS navigation fails

Reported by: openhaus Assigned to: demian (accepted)
Priority: normal Milestone:
Component: module - cms Severity: open
Keywords: cms navigation Cc:

Description

You cannot use the arrows in CMS -> Manage Navigation as the url is misconstructed. It says http://localhost/cms/page/action/reorder/frmPageId/23/targetId/images%5BmoveUpTarget%5D/move/up/ where instead of the "images%5BmoveUpTarget%5D" an integer of the next/previous position should be.

PS: There is no "Component" "module - cms", yet.

Change History

06/05/09 14:28:54 changed by petert

It seems that makeUrl() does not work properly when used in conjunction with Horde_Routes. Same problem in the Navigation module with:

{makeUrl(#reorder#,#section#,#navigation#,results,#frmSectionId|section_id||targetId|images[moveUpTarget]||move|up#,key)}

in the admin_sectionList.html template.

Workaround:

Copy template to /themes/default_admin/<module> and change to:

{makeUrl(#reorder#,#section#,#navigation#)}frmSectionId/{section[section_id]}/targetId/{section[images][moveDownTarget]}/move/down/{key}

(same for moveUp)

08/27/09 08:44:32 changed by demian

  • status changed from new to assigned.
  • component changed from not categorised to module - cms.

12/02/09 04:19:40 changed by demian

  • milestone set to 0.9.1 - polishing.

02/09/10 13:44:55 changed by demian

  • milestone changed from 0.9.1 - polishing to 1.0.

02/26/13 12:29:24 changed by demian

  • milestone deleted.