Ticket #1546 (reopened defect)

Opened 3 years ago

Last modified 3 years ago

redir Form field not set properly

Reported by: hardik Assigned to: demian
Priority: normal Milestone: 1.0
Component: SGL - Url Severity: open
Keywords: redirect, urlencode, urldecode Cc: bijay.rungta@gmail.com

Description

Hi, I am using Windows Server 2003 service pack 1 and IIS 6.0. I have installed the seagull framework and it is installed perfectly. But now when i login as admin, it takes me to the first page but then after if i click any link it re-directs me to the home page. It does not even allow me to log out.

Can you help me with this problem?

Change History

10/20/07 02:32:34 changed by hardik

  • owner changed from somebody to demian.

10/20/07 06:58:59 changed by demian

  • status changed from new to closed.
  • resolution set to invalid.

Hi - this is more of a subject for the forum - Trac is for bugs and patches. See this FAQ for more ideas: http://trac.seagullproject.org/wiki/FAQ/Installation#DoesitworkwithIIS

02/29/08 07:11:17 changed by rungss

  • status changed from closed to reopened.
  • cc set to bijay.rungta@gmail.com.
  • component changed from not categorised to SGL - Url.
  • summary changed from redirected to home page to redir Form field not set properly.
  • priority changed from high to normal.
  • keywords set to redirect, urlencode, urldecode.
  • resolution deleted.

I was facing a Problem and I searched for it here and found this Ticket. I think its a bug When I try to visit http://192.168.0.157/myproject/index.php/default/module/ I am redirected to the following page if I am not logged in: http://192.168.0.157/myproject/index.php/user/login/redir/http%253A%252F%252F192.168.0.157%252Fmyproject%252Findex.php%252Fdefault%252Fmodule%252F/ In this page the value to the form field redir is not set properly it is set to http:, the reason you get redirected to the home page after logging in.

I did some debugging and I see the following output if I add the command

$req->debug();exit;

right after the lines

// assign request to registry $input = &SGL_Registry::singleton(); $req = &SGL_Request::singleton();

in SGL_FrontController::run()

Array (

[moduleName] => user [managerName] => login [redir] => http: [] => 192.168.0.157 [templatekingdom] => index.php [default] => module

)

The Problem is obviously with the character '/' in the parameters..

I am using Horde_Route It used to work fine in the old URL Scheme.

I am trying to resolve this issue. Will update if I find something

03/01/08 11:35:55 changed by demian

  • milestone set to 0.9.0 - polishing.